PyDocs

Nav

Internet Data Handling

EmailPolicy.utf8

If False, follow RFC 5322, supporting non-ASCII characters in headers by encoding them as RFC 2047 “encoded words”. If True, follow RFC 6532 and use utf-8 encoding for headers. Messages formatted in this way may be passed to SMTP servers that support the SMTPUTF8 extension (RFC 6531).
Changed in 3.15
  • 3.15: Can trigger the raising of HeaderWriteError. (Earlier versions incorrectly applied RFC 2047 in certain contexts, mostly notably in addr-specs.)
0 Examples
No examples for email.policy/EmailPolicy.utf8.
See Also
No see-alsos for email.policy/EmailPolicy.utf8
0 Notes
No notes for EmailPolicy.utf8